On Mon, 9 Jan 2023, Lee Jones wrote: > On Mon, 26 Dec 2022, Ilpo Järvinen wrote: > > > Local variables directly interact with dev_get_drvdata/dev_set_drvdata > > should be named ddata. > > > > Co-developed-by: Tianfei zhang <tianfei.zhang@xxxxxxxxx> > > It took 2 people to rename some variables? :) It took one person to rename the variables, and other to prepare it into a series which required some changes to the original patch (which is when I added my SoB). But I can remove Tianfei (Andy mentioned earlier for simple changes it's okay). -- i. > > Signed-off-by: Tianfei zhang <tianfei.zhang@xxxxxxxxx> > > Reviewed-by: Russ Weight <russell.h.weight@xxxxxxxxx> > > Reviewed-by: Xu Yilun <yilun.xu@xxxxxxxxx> > > Signed-off-by: Ilpo Järvinen <ilpo.jarvinen@xxxxxxxxxxxxxxx> > > --- > > drivers/mfd/intel-m10-bmc.c | 10 +++++----- > > 1 file changed, 5 insertions(+), 5 deletions(-) > > > > diff --git a/drivers/mfd/intel-m10-bmc.c b/drivers/mfd/intel-m10-bmc.c > > index 12c522c16d83..2c26203c4799 100644 > > --- a/drivers/mfd/intel-m10-bmc.c > > +++ b/drivers/mfd/intel-m10-bmc.c > > @@ -81,15 +81,15 @@ static DEVICE_ATTR_RO(bmcfw_version); > > static ssize_t mac_address_show(struct device *dev, > > struct device_attribute *attr, char *buf) > > { > > - struct intel_m10bmc *max10 = dev_get_drvdata(dev); > > + struct intel_m10bmc *ddata = dev_get_drvdata(dev); > > In general I'm all for the use of 'ddata' for driver data. > > For my own reference (apply this as-is to your sign-off block): > > Acked-for-MFD-by: Lee Jones <lee@xxxxxxxxxx>