RE: [PATCH v3 2/2] fpga: dfl-pci: Add IDs for Intel N6000, N6001 and C6100 cards

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 





On Mon, 18 Jul 2022, Wu, Hao wrote:

-----Original Message-----
From: matthew.gerlach@xxxxxxxxxxxxxxx <matthew.gerlach@xxxxxxxxxxxxxxx>
Sent: Thursday, July 7, 2022 11:06 PM
To: Wu, Hao <hao.wu@xxxxxxxxx>; Xu, Yilun <yilun.xu@xxxxxxxxx>; Weight,
Russell H <russell.h.weight@xxxxxxxxx>; Muddebihal, Basheer Ahmed
<basheer.ahmed.muddebihal@xxxxxxxxx>; trix@xxxxxxxxxx;
mdf@xxxxxxxxxx; corbet@xxxxxxx; linux-fpga@xxxxxxxxxxxxxxx; linux-
doc@xxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx; Zhang, Tianfei
<tianfei.zhang@xxxxxxxxx>
Cc: Matthew Gerlach <matthew.gerlach@xxxxxxxxxxxxxxx>
Subject: [PATCH v3 2/2] fpga: dfl-pci: Add IDs for Intel N6000, N6001 and
C6100 cards

From: Matthew Gerlach <matthew.gerlach@xxxxxxxxxxxxxxx>

Add pci_dev_table entries supporting the Intel N6000, N6001
and C6100 cards to the dfl-pci driver.

Signed-off-by: Matthew Gerlach <matthew.gerlach@xxxxxxxxxxxxxxx>
Signed-off-by: Tianfei Zhang <tianfei.zhang@xxxxxxxxx>
---
v3: added necessary subdevice ids
    removed 'drivers: ' from title

v2: changed names from INTEL_OFS to INTEL_DFL
---
 drivers/fpga/dfl-pci.c | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/drivers/fpga/dfl-pci.c b/drivers/fpga/dfl-pci.c
index fd1fa55c9113..94eabdf1d2f7 100644
--- a/drivers/fpga/dfl-pci.c
+++ b/drivers/fpga/dfl-pci.c
@@ -77,12 +77,19 @@ static void cci_pci_free_irq(struct pci_dev *pcidev)
 #define PCIE_DEVICE_ID_INTEL_PAC_D5005		0x0B2B
 #define PCIE_DEVICE_ID_SILICOM_PAC_N5010	0x1000
 #define PCIE_DEVICE_ID_SILICOM_PAC_N5011	0x1001
+#define PCIE_DEVICE_ID_INTEL_DFL		0xbcce

 /* VF Device */
 #define PCIE_DEVICE_ID_VF_INT_5_X		0xBCBF
 #define PCIE_DEVICE_ID_VF_INT_6_X		0xBCC1
 #define PCIE_DEVICE_ID_VF_DSC_1_X		0x09C5
 #define PCIE_DEVICE_ID_INTEL_PAC_D5005_VF	0x0B2C
+#define PCIE_DEVICE_ID_INTEL_DFL_VF		0xbccf
+
+/* PCI Subdevice ID */
+#define PCIE_SUBDEVICE_ID_INTEL_N6000		0x1770
+#define PCIE_SUBDEVICE_ID_INTEL_N6001		0x1771
+#define PCIE_SUBDEVICE_ID_INTEL_C6100		0x17d4

Please move SUBDEVICE_ID above together with DEVICE_ID.
If we add new SUBDEVICE to some other device like this, it will
be hard to distinguish them.

This is a very good suggestion.  I will resubmit with your suggestion.

Thanks for the review.
Matthew

With above change.
Acked-by: Wu Hao <hao.wu@xxxxxxxxx>

Thanks
Hao





[Index of Archives]     [LM Sensors]     [Linux Sound]     [ALSA Users]     [ALSA Devel]     [Linux Audio Users]     [Linux Media]     [Kernel]     [Gimp]     [Yosemite News]     [Linux Media]

  Powered by Linux