RE: [PATCH v4] uio: dfl: add HSSI subsystem feature id

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




> -----Original Message-----
> From: Xu, Yilun <yilun.xu@xxxxxxxxx>
> Sent: Thursday, May 5, 2022 10:16 AM
> To: Zhang, Tianfei <tianfei.zhang@xxxxxxxxx>
> Cc: Wu, Hao <hao.wu@xxxxxxxxx>; trix@xxxxxxxxxx; mdf@xxxxxxxxxx; linux-
> fpga@xxxxxxxxxxxxxxx; gregkh@xxxxxxxxxxxxxxxxxxx; linux-
> kernel@xxxxxxxxxxxxxxx; Matthew Gerlach <matthew.gerlach@xxxxxxxxxxxxxxx>
> Subject: Re: [PATCH v4] uio: dfl: add HSSI subsystem feature id
> 
> On Wed, May 04, 2022 at 08:16:28PM -0400, Tianfei Zhang wrote:
> > From: Matthew Gerlach <matthew.gerlach@xxxxxxxxxxxxxxx>
> >
> > Add the Device Feature List (DFL) feature id for the High Speed Serial
> > Interface (HSSI) Subsystem to the table of ids supported by the
> > uio_dfl driver.
> >
> > The HSSI Subsystem is a configurable set of IP blocks to be used as
> > part of a Ethernet or PCS/FEC/PMA pipeline.
> > Like the Ethernet group used by the N3000 card, the HSSI Subsystem
> > does not fully implement a network device from a Linux netdev
> > perspective and is controlled and monitored from user space software
> > via the uio interface.
> >
> > The Feature ID table of DFL can be found:
> > https://github.com/OPAE/dfl-feature-id
> >
> > Reviewed-by: Tom Rix <trix@xxxxxxxxxx>
> > Acked-by: Xu Yilun <yilun.xu@xxxxxxxxx>
> > Signed-off-by: Matthew Gerlach <matthew.gerlach@xxxxxxxxxxxxxxx>
> > Signed-off-by: Tianfei Zhang <tianfei.zhang@xxxxxxxxx>
> 
> Please re-order the tags. The earliest at the top and the latest at the bottom.
> 
> "SoB chains should reflect the **real** route a patch took as it was propagated
> to the maintainers and ultimately to Linus, with the first SoB entry signalling
> primary authorship of a single author."
> 
> For more details, please refer to Documentation/process/submitting-patches.rst
> 
> 
> For you case, I assume:
> 
>   Signed-off-by: Matthew Gerlach <matthew.gerlach@xxxxxxxxxxxxxxx>
>   Signed-off-by: Tianfei Zhang <tianfei.zhang@xxxxxxxxx>
>   Reviewed-by: Tom Rix <trix@xxxxxxxxxx>
>   Acked-by: Xu Yilun <yilun.xu@xxxxxxxxx>
> 
> is it?

Yes, I agree, I will send a new one.

> 
> Thanks,
> Yilun
> 
> 
> > ---
> > v4: add Reviewed-by and Acked-by tag and add Feature ID table url in git
> message.
> > v3: change the name of this feature id to HSSI_SUBSYS and rewrite
> >     the git message.
> > v2: add HSSI introduction and the git repo of Feature ID table.
> > ---
> >  drivers/uio/uio_dfl.c | 2 ++
> >  1 file changed, 2 insertions(+)
> >
> > diff --git a/drivers/uio/uio_dfl.c b/drivers/uio/uio_dfl.c index
> > 89c0fc7b0cbc..8f39cc8bb034 100644
> > --- a/drivers/uio/uio_dfl.c
> > +++ b/drivers/uio/uio_dfl.c
> > @@ -45,9 +45,11 @@ static int uio_dfl_probe(struct dfl_device *ddev)
> > }
> >
> >  #define FME_FEATURE_ID_ETH_GROUP	0x10
> > +#define FME_FEATURE_ID_HSSI_SUBSYS	0x15
> >
> >  static const struct dfl_device_id uio_dfl_ids[] = {
> >  	{ FME_ID, FME_FEATURE_ID_ETH_GROUP },
> > +	{ FME_ID, FME_FEATURE_ID_HSSI_SUBSYS },
> >  	{ }
> >  };
> >  MODULE_DEVICE_TABLE(dfl, uio_dfl_ids);
> > --
> > 2.26.2




[Index of Archives]     [LM Sensors]     [Linux Sound]     [ALSA Users]     [ALSA Devel]     [Linux Audio Users]     [Linux Media]     [Kernel]     [Gimp]     [Yosemite News]     [Linux Media]

  Powered by Linux