..snip.. On 2/2/21 3:06 PM, Russ Weight wrote: > diff --git a/drivers/fpga/dfl-afu.h b/drivers/fpga/dfl-afu.h > index 576e94960086..e5020e2b1f3d 100644 > --- a/drivers/fpga/dfl-afu.h > +++ b/drivers/fpga/dfl-afu.h > @@ -80,7 +80,7 @@ struct dfl_afu { > }; > > /* hold pdata->lock when call __afu_port_enable/disable */ > -void __afu_port_enable(struct platform_device *pdev); > +int __afu_port_enable(struct platform_device *pdev); > int __afu_port_disable(struct platform_device *pdev); > Should the '__' prefix be removed from __afu_port* ? This would make the function names consistent with the other decls Tom > void afu_mmio_region_init(struct dfl_feature_platform_data *pdata);