On Tue, Jul 21, 2020 at 07:41:27PM +0800, Wu, Hao wrote: > > > > +} > > > > + > > > > +dfl_dev->type = feature_dev_id_type(pdev); > > > > +dfl_dev->feature_id = (unsigned long long)feature->id; > > > > + > > > > +dfl_dev->dev.parent = &pdev->dev; > > > > +dfl_dev->dev.bus = &dfl_bus_type; > > > > +dfl_dev->dev.release = release_dfl_dev; > > > > +dev_set_name(&dfl_dev->dev, "%s.%d", dev_name(&pdev->dev), > > > > + feature->index); > > > > > > Or it's better to have a generic name for the device on the bus. > > > > mm.. It is good suggestion, we should have a unified name for dfl > > devices. > > > > How about ("dfl.%d.%d", pdev->id, feature->index) > > It's quite difficult for people to use related information from these magic > numbers. They are not ids defined in the spec, so just dfl_dev.x with one > unique id seems to be better. If you really need to expose some id > information, maybe you can consider adding some standard sysfs entry > to all dfl_dev, I think that will be easier for users. How do you think? I'm fine with the dfl_dev.x solution. > > Thanks > Hao