On Tue, Mar 24, 2020 at 02:45:03PM +0100, Bartlomiej Zolnierkiewicz wrote: > Use in_le32() instead of le32_to_cpup() to fix sparse warning about > improper type of the argument. > > Also add missing inline keyword to control_par_to_var() definition > (to match function prototype). > > Acked-by: Sam Ravnborg <sam@xxxxxxxxxxxx> > Signed-off-by: Bartlomiej Zolnierkiewicz <b.zolnierkie@xxxxxxxxxxx> > --- > drivers/video/fbdev/controlfb.c | 5 +++-- > 1 file changed, 3 insertions(+), 2 deletions(-) > > diff --git a/drivers/video/fbdev/controlfb.c b/drivers/video/fbdev/controlfb.c > index 38b61cdb5ca4..9625792f4413 100644 > --- a/drivers/video/fbdev/controlfb.c > +++ b/drivers/video/fbdev/controlfb.c > @@ -313,7 +313,7 @@ static int controlfb_blank(int blank_mode, struct fb_info *info) > container_of(info, struct fb_info_control, info); > unsigned ctrl; > > - ctrl = le32_to_cpup(CNTRL_REG(p,ctrl)); > + ctrl = in_le32(CNTRL_REG(p, ctrl)); > if (blank_mode > 0) > switch (blank_mode) { > case FB_BLANK_VSYNC_SUSPEND: > @@ -952,7 +952,8 @@ static int control_var_to_par(struct fb_var_screeninfo *var, > * Convert hardware data in par to an fb_var_screeninfo > */ > > -static void control_par_to_var(struct fb_par_control *par, struct fb_var_screeninfo *var) > +static inline void control_par_to_var(struct fb_par_control *par, Just quick drive-by bikeshed, feel free to ignore: static inline within a .c file imo doesn't make sense anymore, compilers are smart enough nowadays. I'd just drop this. -Daniel > + struct fb_var_screeninfo *var) > { > struct control_regints *rv; > > -- > 2.24.1 > > _______________________________________________ > dri-devel mailing list > dri-devel@xxxxxxxxxxxxxxxxxxxxx > https://lists.freedesktop.org/mailman/listinfo/dri-devel -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch