On Wed, Mar 22, 2017 at 3:49 AM, Arushi Singhal <arushisinghal19971997@xxxxxxxxx> wrote: > @@ -232,7 +232,7 @@ static int ad7150_write_event_config(struct iio_dev *indio_dev, > if (ret < 0) > goto error_ret; > > - cfg = ret & ~((0x03 << 5) | (0x1 << 7)); > + cfg = ret & ~((0x03 << 5) | (BIT(7))); > > switch (type) { > case IIO_EV_TYPE_MAG_ADAPTIVE: While the change in the #defines is not unusual, this particular change here makes it harder to read, so I'd recommend leaving it alone, or changing it to use symbolic names instead of the bit masks. > /* Voltage/Temperature Setup Register Bit Designations (AD7746_REG_VT_SETUP) */ > -#define AD7746_VTSETUP_VTEN (1 << 7) > +#define AD7746_VTSETUP_VTEN (BIT(7)) > #define AD7746_VTSETUP_VTMD_INT_TEMP (0 << 5) > -#define AD7746_VTSETUP_VTMD_EXT_TEMP (1 << 5) > +#define AD7746_VTSETUP_VTMD_EXT_TEMP (BIT(5)) Why did you leave one of them unchanged? Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-fbdev" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html