Re: [PATCH] video: fbdev: offb: switch to using for_each_node_by_type

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

On Tuesday, January 31, 2017 10:25:36 AM Dmitry Torokhov wrote:
> Instead of open-coding loops let's switch to a nice macro.
> 
> Signed-off-by: Dmitry Torokhov <dmitry.torokhov@xxxxxxxxx>

Patch queued for 4.11, thanks.

> ---
>  drivers/video/fbdev/offb.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/video/fbdev/offb.c b/drivers/video/fbdev/offb.c
> index 906c6e75c260..9be884b0c778 100644
> --- a/drivers/video/fbdev/offb.c
> +++ b/drivers/video/fbdev/offb.c
> @@ -668,14 +668,14 @@ static int __init offb_init(void)
>  		offb_init_nodriver(of_chosen, 1);
>  	}
>  
> -	for (dp = NULL; (dp = of_find_node_by_type(dp, "display"));) {
> +	for_each_node_by_type(dp, "display") {
>  		if (of_get_property(dp, "linux,opened", NULL) &&
>  		    of_get_property(dp, "linux,boot-display", NULL)) {
>  			boot_disp = dp;
>  			offb_init_nodriver(dp, 0);
>  		}
>  	}
> -	for (dp = NULL; (dp = of_find_node_by_type(dp, "display"));) {
> +	for_each_node_by_type(dp, "display") {
>  		if (of_get_property(dp, "linux,opened", NULL) &&
>  		    dp != boot_disp)
>  			offb_init_nodriver(dp, 0);

Best regards,
--
Bartlomiej Zolnierkiewicz
Samsung R&D Institute Poland
Samsung Electronics

--
To unsubscribe from this list: send the line "unsubscribe linux-fbdev" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Video for Linux]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite Tourism]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux