Looks fine to me in principle, but a few nitpicks. First, the short commit message should be in imperative form, i.e., "Add a callback..." On Mon, Aug 08, 2011 at 03:37:55AM -0700, Dilan Lee wrote: > From: Dilan Lee <dilee@xxxxxxxxxx> > > We need a callback to do some things after pwm_enable,pwm_disable > and pwm_config. Add a space between "pwm_enable,pwm_disable" > For example, GPIO backlight_en has to be rised after pwm has been enabled > to meet panel power on sequence defined in panel specification. There's a typo in "raised" above, but really, this paragraph should be omitted entirely. Without context, it doesn't make any sense. If more motivation that the previous paragraph is necessary, maybe add something like "This may be necessary to properly sequence timing on certain devices." > unsigned int lth_brightness; > int (*notify)(struct device *, > int brightness); > + void (*notify_after)(struct device *, > + int brightness); The indentation here looks a bit off; notify_after should be lined up with notify and check_fb, and int brightness doesn't need the extra spaces since the notify_after argument list starts on a tab boundary. Otherwise, Reviewed-by: Robert Morell <rmorell@xxxxxxxxxx> Thanks, Robert -- To unsubscribe from this list: send the line "unsubscribe linux-fbdev" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html