On 16 November 2010 08:26, Michael Grzeschik <mgr@xxxxxxxxxxxxxx> wrote: > I rechecked the Datasheet and it seems you are right with that. > But i don't like the logical mess in the statements. So here is what i > would prefer. > >> >> - if (info->var.sync & FB_SYNC_HOR_HIGH_ACT) >> + if (!(info->var.sync & FB_SYNC_HOR_HIGH_ACT)) >> temp |= FP_PT2_HSP; > > Instead i would like to see something like this: > > > if (info->var.sync & FB_SYNC_HOR_HIGH_ACT) > temp &= ~(FP_PT2_HSP); You'd have to add an else condition to actually set the bit (in the active low case) though. I'd be happy to do that, but my opinion is that my original version is cleaner. Apples vs oranges. Paul, which approach do you prefer? Thanks, Daniel -- To unsubscribe from this list: send the line "unsubscribe linux-fbdev" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html