Hi Gabriel, all, I merged Matthew's v3 FAN_REPORT_PIDFD, which is for 5.15 kernel. Could you please rebase your changes on the top of current master? Unfortunately that means to rename fanotify21.c in all commits. Also please: s/REQUIRE_MARK_TYPE_SUPPORTED_ON_KERNEL/REQUIRE_MARK_TYPE_SUPPORTED_BY_KERNEL/ and other changes: diff --git testcases/kernel/syscalls/fanotify/fanotify21.c testcases/kernel/syscalls/fanotify/fanotify21.c index 7f0154da5..44882097b 100644 --- testcases/kernel/syscalls/fanotify/fanotify21.c +++ testcases/kernel/syscalls/fanotify/fanotify21.c @@ -131,7 +131,7 @@ int check_error_event_info_fid(struct fanotify_event_info_fid *fid, if (memcmp(&fid->fsid, &ex->fid->fsid, sizeof(fid->fsid))) { tst_res(TFAIL, "%s: Received bad FSID type (%x...!=%x...)", ex->name, FSID_VAL_MEMBER(fid->fsid, 0), - FSID_VAL_MEMBER(ex->fid->fsid, 0)); + ex->fid->fsid.val[0]); return 1; } @@ -298,7 +298,6 @@ static struct tst_test test = { .cleanup = cleanup, .mount_device = 1, .mntpoint = MOUNT_PATH, - .all_filesystems = 0, .needs_root = 1, .dev_fs_type = "ext4", .needs_cmds = (const char *[]) { Thanks! Petr