On Tue, Feb 18, 2020 at 07:28:26PM -0800, Eric Biggers wrote: > On Mon, Feb 17, 2020 at 10:45:58AM -0800, Matthew Wilcox wrote: > > diff --git a/include/linux/mpage.h b/include/linux/mpage.h > > index 001f1fcf9836..f4f5e90a6844 100644 > > --- a/include/linux/mpage.h > > +++ b/include/linux/mpage.h > > @@ -13,9 +13,9 @@ > > #ifdef CONFIG_BLOCK > > > > struct writeback_control; > > +struct readahead_control; > > > > -int mpage_readpages(struct address_space *mapping, struct list_head *pages, > > - unsigned nr_pages, get_block_t get_block); > > +void mpage_readahead(struct readahead_control *, get_block_t get_block); > > int mpage_readpage(struct page *page, get_block_t get_block); > > int mpage_writepages(struct address_space *mapping, > > struct writeback_control *wbc, get_block_t get_block); > > Can you name the 'struct readahead_control *' parameter? What good would that do? I'm sick of seeing 'struct page *page'. Well, no shit it's a page. Unless there's some actual information to convey, leave the argument unnamed. It should be a crime to not name an unsigned long, but not naming the struct address_space pointer is entirely reasonable.