Hi, Martin, On 20.12.2019 01:37, Martin K. Petersen wrote: > > Kirill, > >> Hm. BLKDEV_ZERO_NOUNMAP is used in __blkdev_issue_write_zeroes() only. >> So, do I understand right that we should the below two?: >> >> 1) Introduce a new flag BLKDEV_ZERO_ALLOCATE for >> blkdev_issue_write_zeroes(). > >> 2) Introduce a new flag REQ_NOZERO in enum req_opf. > > Something like that. If zeroing is a problem for you. My intention is to use this in fs allocators to notify virtual block devices about allocated blocks (like in patch [3/3]). Filesystems allocators know about written and unwritten extents, and they don't need a zeroing of allocated blocks. Since a block range allocation action is less complicated (and faster), than operation of allocation + zeroing of allocated blocks (at least for some devices), we just choose it as the fastest. This is the reason we avoid zeroing. > Right now we offer the following semantics: > > Deallocate, no zeroing (discard) > > Optionally deallocate, zeroing (zeroout) > > Allocate, zeroing (zeroout + NOUNMAP) > > Some devices also implement a fourth option which would be: > > Anchor: Allocate, no zeroing > >> Won't this confuse a reader that we have blkdev_issue_write_zeroes(), >> which does not write zeroes sometimes? Maybe we should rename >> blkdev_issue_write_zeroes() in some more generic name? > > Maybe. The naming is what it is for hysterical raisins and reflects how > things are implemented in the storage protocols. I wouldn't worry too > much about that. We can rename things if need be but we shouldn't plumb > an essentially identical operation through the block stack just to > expose a different name at the top. Not introduction a new operation is a good thing. Especially, since we don't need a specific max_xxx_xxx_sectors != max_write_zeroes_sectors for it. I'll rework the patch in this way (it seems it will become pretty small after that). One more thing to discuss. The new REQ_NOZERO flag won't be supported by many block devices (their number will be even less, than number of REQ_OP_WRITE_ZEROES supporters). Will this be a good thing, in case of we will be completing BLKDEV_ZERO_ALLOCATE bios in __blkdev_issue_write_zeroes() before splitting? I mean introduction of some flag in struct request_queue::limits. Completion of them with -EOPNOTSUPP in block devices drivers looks suboptimal for me. Thanks, Kirill