On Mar 6, 2018, at 8:18 AM, Artem Blagodarenko <artem.blagodarenko@xxxxxxxxx> wrote: > -#define EXT2_DIR_REC_LEN(name_len) (((name_len) + \ > +#define __EXT2_DIR_REC_LEN(name_len) (((name_len) + \ > EXT2_DIR_ENTRY_HEADER_LEN + \ > EXT2_DIR_ROUND) & \ > ~EXT2_DIR_ROUND) > > +#define EXT2_DIR_REC_LEN(de) (__EXT2_DIR_REC_LEN(((de)->name_len & \ > + EXT2_NAME_LEN) + \ > + ext2_get_dirdata_size(de))) It would be good to rename these to match the macro names used in the ext4 kernel patch accepted upstream. > @@ -2900,6 +2901,13 @@ int main (int argc, char *argv[]) > exit(1); > } > > + if (ext2fs_has_feature_inline_data(fs->super) && > + ext2fs_has_feature_dirdata(fs->super)) { > + printf("%s", _("The dirdata feature can not enabled " > + "with inline data feature.\n")); Is this something that is fixed in a later patch? I don't recall the details of why these two features do not work together... I can imagine in the case of inline directories that there is additional complexity in handling dirdata packed inside the inode xattr space, but for regular files (i.e. most files in a filesystem) the dirdata and inline data features are orthogonal and it would be useful to have both enabled. Obviously not something to implement in this patch, but definitely something that would be useful to have in a follow-on patch. Cheers, Andreas
Attachment:
signature.asc
Description: Message signed with OpenPGP