> Tashin, we are already using the "no_mbcache" option name, so would prefer > to keep that working. It would be OK to accept both option names to mean > the same thing, and only document the "nombcache" option. Updated patch to accept both nombcache and no_mbcache. >> struct mb_cache *s_mb_cache; >> + struct mb_cache *s_ea_inode_cache; > > These names should be consistent, like "s_ea_block_cache". Yes, I will rename this to s_ea_block_cache. >> #define EXT4_GET_MB_CACHE(inode) (((struct ext4_sb_info *) \ >> inode->i_sb->s_fs_info)->s_mb_cache) >> >> +#define EA_INODE_CACHE(inode) (((struct ext4_sb_info *) \ >> + inode->i_sb->s_fs_info)->s_ea_inode_cache) > > These names should be consistent, like EXT4_GET_EA_CACHE() or maybe > EXT4_GET_EA_BLOCK_CACHE() and EXT4_GET_EA_INODE_CACHE(). How about EA_BLOCK_CACHE() and EA_INODE_CACHE() to keep them short?