On Mon, 2012-06-11 at 16:16 +0530, Saugata Das wrote: > +/* Get the context of the buffer within the underlying storage device */ > +static int ext4_get_context(struct page *page) > +{ > + if (page && page->mapping && page->mapping->host) > + return page->mapping->host->i_ino; > + else > + return 0; > +} Word "context" is very generic and it is widely used various things, and I believe we should try to avoid overloading this term and obfuscating the I/O stack with various functions and other identifiers like "get_context()". This would hurt readability. It is fine to use it withing the UFS-specific code, but not globally withing the kernel code. I do not really have good name candidates, but even "ufscontext" is already better than just "context". Or "iocontext" ? Or just "ufsdata" ? -- Best Regards, Artem Bityutskiy
Attachment:
signature.asc
Description: This is a digitally signed message part