Re: [patch 1/1] ext4: use proper little-endian bitops

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, 29 Jul 2011, Akinobu Mita wrote:

> 2011/7/29 Lukas Czerner <lczerner@xxxxxxxxxx>:
> > On Fri, 29 Jul 2011, Akinobu Mita wrote:
> >
> >> 2011/7/29 Lukas Czerner <lczerner@xxxxxxxxxx>:
> >>
> >> >> diff -puN fs/ext4/ext4.h~ext4-use-proper-little-endian-bitops fs/ext4/ext4.h
> >> >> --- a/fs/ext4/ext4.h~ext4-use-proper-little-endian-bitops
> >> >> +++ a/fs/ext4/ext4.h
> >> >> @@ -931,12 +931,13 @@ struct ext4_inode_info {
> >> >>  #define test_opt2(sb, opt)           (EXT4_SB(sb)->s_mount_opt2 & \
> >> >>                                        EXT4_MOUNT2_##opt)
> >> >>
> >> >> -#define ext4_set_bit                 __test_and_set_bit_le
> >> >> +#define ext4_test_and_set_bit                __test_and_set_bit_le
> >> >> +#define ext4_set_bit                 __set_bit_le
> >> >>  #define ext4_set_bit_atomic          ext2_set_bit_atomic
> >> > We can remove this since it is not used anywhere and it is just a macro
> >> > for test_and_set_bit_le() anyway.
> >>
> >> Amir Goldstein requested not to remove it because ext4 snapshot patches is
> >> using ext4_set_bit_atomic(), although I really don't know about the status of
> >> mainline inclusion.
> >
> > It is not anywhere near inclusion. Moreover it is using
> > __test_and_set_bit_le, but the name does not really imply *test*.
> 
> BTW, do you think of anything more preferable name?  Because ext[23] and
> nilfs2 are still using them, so renaming can avoid confusion.

Well, it is the same situation as you are fixing with this ext4 patch.
So ext2_test_and_set_bit_atomic seems ok, but I really wonder if we need
to call it ext2_* since it is not ext2 specific.

Maybe it would be nice to rename it, as well as move it into different
file, or just rename the file. But it is not *very* important I guess.

> 
> > So please, just remove it and when Amir is going to
> > need it someday he might add proper define with the proper name using
> > the proper set, or test_and_set functions.
> 
> OK, I'll remove if no one has strong objection against it.
> 

Thanks!

[Index of Archives]     [Reiser Filesystem Development]     [Ceph FS]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Linux FS]     [Yosemite National Park]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Device Mapper]     [Linux Media]

  Powered by Linux