On Sat, Jan 22, 2011 at 9:40 PM, Ted Ts'o <tytso@xxxxxxx> wrote: > On Sat, Jan 22, 2011 at 07:32:44PM -0800, Manish Katiyar wrote: >> Hi Jan, >> >> This is the follow up from https://lkml.org/lkml/2011/1/17/154 >> Following patches make jbd2 to use GFP_KERNEL for transaction >> allocation if the caller can handle the errors. Following is the list >> of functions that I updated to pass the new flag. Also below is the >> list of functions which still have the old behavior and pass the old >> flags (either because they can't deal with errors, or I wasn't too >> sure so I did conservatively). Appreciate your feedback. The other >> callers of jbd2_journal_start() are from ocfs2, they still pass the >> old flag. > > Hmm, I wonder if it would be better to use > > jbd2_journal_start(...) > > and > > jbd2_journal_start_nofail(...) > > The tradeoff is that long-term, the code is more readable (as opposed > to having people look up what a random "true" or "false" value means). > But short-term, while it will make the patch smaller, it also makes > the patch harder audit, since we need to look at all of the places > where we _haven't_ made a change to make sure those call sites can > tolerate an error return. Yes, a new interface is better but wasn't too sure. If the reviewers feel that is the way to go I can redo. Infact if this version makes review easier, then once these changes look ok and agreed, I can submit an updated version with these changes applied using the new interface. Will that make sense ? -- Thanks - Manish -- To unsubscribe from this list: send the line "unsubscribe linux-ext4" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html