On Fri, Nov 21, 2008 at 12:51:10PM -0500, Christoph Hellwig wrote: > On Fri, Nov 21, 2008 at 10:10:36PM +0530, Aneesh Kumar K.V wrote: > > #define EXT4_HAS_COMPAT_FEATURE(sb,mask) \ > > - (EXT4_SB(sb)->s_es->s_feature_compat & cpu_to_le32(mask)) > > + (__force __u32)!!(EXT4_SB(sb)->s_es->s_feature_compat & \ > > + cpu_to_le32(mask)) > > As mentioned before please don't abuse __force here. > > ((EXT4_SB(sb)->s_es->s_feature_compat & cpu_to_le32(mask)) != 0) > > does the right things and is a lote more readable. I thought your comment was on returning value that had multiple flag bit set. I didn't look at the __force usage as bad. I will send an updated patch. -aneesh -- To unsubscribe from this list: send the line "unsubscribe linux-ext4" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html