Hello Eric,
Change the name of functions (ext4_ext_xxx -> ext4_defrag_xxx)
and some cleanups.
-int ext4_ext_walk_space(struct inode *inode, ext4_lblk_t block,
- ext4_lblk_t num, ext_prepare_callback func,
- void *cbdata)
-{
We were just going to be using this function for the FIEMAP support.
I think there are several other functions which are not specific
to defrag, so they shouldn't be renamed to be defrag specific.
ext4_ext_walk_space is no longer used by ext4 online defrag.
So I just removed from defrag.c not renamed.
Shouldn't I remove ext4_ext_walk_space from defrag
for support FIEMAP?
I think it should be moved to extents.c
I agree. I'm working on FIEMAP, and I'll put it back into extents.c
along with the FIEMAP patch, if you don't need it for defrag.
OK. Please put ext4_ext_walk_space in extents.c.
Thank you for coping. :-)
Cheers Akira
--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html