On Tue, May 03, 2022 at 04:12:55PM +0200, Borislav Petkov wrote: > On Mon, Apr 25, 2022 at 06:39:28AM +0300, Kirill A. Shutemov wrote: > > diff --git a/arch/x86/boot/compressed/kaslr.c b/arch/x86/boot/compressed/kaslr.c > > index 411b268bc0a2..59db90626042 100644 > > --- a/arch/x86/boot/compressed/kaslr.c > > +++ b/arch/x86/boot/compressed/kaslr.c > > @@ -725,10 +725,20 @@ process_efi_entries(unsigned long minimum, unsigned long image_size) > > * but in practice there's firmware where using that memory leads > > * to crashes. > > * > > - * Only EFI_CONVENTIONAL_MEMORY is guaranteed to be free. > > + * Only EFI_CONVENTIONAL_MEMORY and EFI_UNACCEPTED_MEMORY (if > > + * supported) are guaranteed to be free. > > */ > > - if (md->type != EFI_CONVENTIONAL_MEMORY) > > + > > + switch (md->type) { > > + case EFI_CONVENTIONAL_MEMORY: > > + break; > > + case EFI_UNACCEPTED_MEMORY: > > + if (IS_ENABLED(CONFIG_UNACCEPTED_MEMORY)) > > + break; > > continue; > > + default: > > + continue; > > + } > > Is there any special reason for this to be a switch-case or can it > simply be a compound conditional if (bla...) ? The equivalent 'if' statement is something like: if (md->type != EFI_CONVENTIONAL_MEMORY && !(md->type == EFI_UNACCEPTED_MEMORY && IS_ENABLED(CONFIG_UNACCEPTED_MEMORY))) continue; I find it harder to follow. Do you want me to change to the 'if' anyway? -- Kirill A. Shutemov