On Fri, Apr 24, 2015 at 02:07:19PM +0800, Firo Yang wrote: > diff --git a/arch/x86/platform/efi/efi_64.c b/arch/x86/platform/efi/efi_64.c > index a0ac0f9..62326c4 100644 > --- a/arch/x86/platform/efi/efi_64.c > +++ b/arch/x86/platform/efi/efi_64.c > @@ -90,6 +90,8 @@ pgd_t * __init efi_call_phys_prolog(void) > > n_pgds = DIV_ROUND_UP((max_pfn << PAGE_SHIFT), PGDIR_SIZE); > save_pgd = kmalloc(n_pgds * sizeof(pgd_t), GFP_KERNEL); > + if (unlikely(!save_pgd)) > + return NULL; A bunch of init code doesn't check for NULL because it won't happen in real life. It makes my life a little bit harder because it introduces meaningless static checker warnings... Oh well. Don't add unlikely() here because it won't help with benchmarks and it makes the code harder to read. regards, dan carpenter -- To unsubscribe from this list: send the line "unsubscribe linux-efi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html