On Fri, Mar 07, 2014 at 02:20:56PM +0300, Dan Carpenter wrote: > In phys_efi_get_time() we call efi_call_phys_prelog() with a spin_lock > so this allocation should be atomic. > > Fixes: b8f2c21db390 ('efi, x86: Pass a proper identity mapping in efi_call_phys_prelog') > Signed-off-by: Dan Carpenter <dan.carpenter@xxxxxxxxxx> > > diff --git a/arch/x86/platform/efi/efi_64.c b/arch/x86/platform/efi/efi_64.c > index 0c2a234fef1e..f5adcadb381b 100644 > --- a/arch/x86/platform/efi/efi_64.c > +++ b/arch/x86/platform/efi/efi_64.c > @@ -90,7 +90,7 @@ void __init efi_call_phys_prelog(void) > local_irq_save(efi_flags); > > n_pgds = DIV_ROUND_UP((max_pfn << PAGE_SHIFT), PGDIR_SIZE); > - save_pgd = kmalloc(n_pgds * sizeof(pgd_t), GFP_KERNEL); > + save_pgd = kmalloc(n_pgds * sizeof(pgd_t), GFP_ATOMIC); "save_pgd" is a file scope variable. It wouldn't be that hard to move the allocation to a different function. Meanwhile I am on the way to the airport for vacation. See you guys in couple weeks. regards, dan carpenter -- To unsubscribe from this list: send the line "unsubscribe linux-efi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html