On Friday 12 May 2006 00:54, Trent Piepho wrote: > Some code had gratuituous gotos that just didn't serve any purpose at all. > Something like: > > [...] > goto success; > failure: > kfree(something); > return 0; > success: > return 1; > } > > Changed to: > > [...] > return 1; > > failure: > kfree(something); > return 0; > } > > The latter form is easier to understand, shorter, uses fewer gotos, and > much more common in the dvb code than the former. Will apply, but I need your Signed-off-line too do so (sorry). _______________________________________________ linux-dvb@xxxxxxxxxxx http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb