Re: [PATCH] Multi protocol support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Johannes Stezenbach wrote:
On Wed, Apr 12, 2006, Manu Abraham wrote:
Andreas Oberritter wrote:
+typedef enum {
+       DMX_PROTO_DVB_S,
+       DMX_PROTO_DVB_C,
+       DMX_PROTO_DVB_T,
+       DMX_PROTO_DSS,
+       DMX_PROTO_ATSC,
+       DMX_PROTO_DVB_S2
+} dmx_protocol_t;
Why should a demux care how the TS was delivered? All DVB variants and
ATSC use MPEG-2 TS, right? I don't know about DSS though.
Some protocols need different SYNC words , stream lengths etc for the demuxer to work (DSS and DVB-S2 differ from DVB-S/C/T/ATSC) DSS has a different SYNC word and a different stream lengths, but S2 has more modes of operation which again needs this.

So there are 3 different categories
(1) DVB--> DVB-S/C/T/ATSC
(2) DSS
(3) DVB-S2 --> multiple modes

"Protocol" is wrong, it should be named "transport stream format",

A delivery system sounds acceptable ?

typedef enum {
   FE_DELSYS_DVB_S        = 0x00000001,
   FE_DELSYS_DVB_S2        = 0x00000002,
   FE_DELSYS_DVB_C,        = 0x00000004,
   FE_DELSYS_DVB_T,        = 0x00000008,
   FE_DELSYS_DSS            = 0x00000010,
   FE_DELSYS_ATSC        = 0x00000020
} fe_delsys_t;


and there are:
- MPEG-2 TS
- DSS
- DVB-S2 whatever (I don't know about that)

My guess is that you will have trouble finding a DVB-S2 stream
which does not use MPEG2-TS. You're ahead of your time.

yeah, for the normal operation modes only the TS mode is used, the other modes are used for DSNG etc.

well, i found it in the specs, so i thought it would be easier to do it. The reason being anyway need to add the information for DSS and DVB-S2 specs also point in that direction, so i believe to have it defined would be the easier and less confusion later on.

For DSS you'd also need to implement a different demux (with
a different demux API).

Yeah, you are right. Additionally it will need an adapter object as well, since some bridges need specific settings for the aligned transfer and the SYNC words. Ralph was of the suggestion that we should add other bridge specifics into it , like a bridge RESET etc. Still working on it, in relevance to the stb0899.


Manu


_______________________________________________

linux-dvb@xxxxxxxxxxx
http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

[Index of Archives]     [Linux Media]     [Video 4 Linux]     [Asterisk]     [Samba]     [Xorg]     [Xfree86]     [Linux USB]

  Powered by Linux