On Wed, Mar 22, 2006, Marcel Siegert wrote: > +struct dvb_fe_caps_extended { > + __u32 caps_fec; /* supported fecs */ > + __u32 caps_modulation; /* supported modulations */ > + __u32 caps_frontends_avail; /* supported frontend_types */ How about naming those "fecs", "modulations" and "standards"? > +#define dvb_qpsk_parameters dvb_dvbs_parameters > +#define dvb_qam_parameters dvb_dvbc_parameters > +#define dvb_ofdm_parameters dvb_dvbt_parameters Might as well add vsb==atsc. > +struct dvb_frontend_parameters_extended { > + union { > + struct dvb_dvbs2_parameters qpsk2; > + } u; > +}; Why not simply "union dvb_frontend_parameters_extended"? > +/** > + * use to set the FE_STANDARD - if a tuner supports more than one type. e.g. DVB-C/T or DVB-S/S2 combi frontends > + * after FE_SET_STANDARD was set, the drivers has to make sure still to reflect the standards available, but > + * capabilities should be adjusted to the selected stanadard typo "stanadard", lines are too long > + */ > +#define FE_SET_STANDARD _IO('o', 84) /* fe_type_t */ > + > +/** > + * used to query the api v4 backported capabilities (see above for details) better not confuse people by mentioning v4 api Johannes _______________________________________________ linux-dvb@xxxxxxxxxxx http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb