> + state->tx_tuna[8] =~ 0x40; //1 > + state->tx_tuna[8] |= 0x40; // 0 I don't know anything about that device, but this code looks wrong to me. The "1" line sets the whole register and the "0" line a single bit. Shouldn't that rather be something like > + state->tx_tuna[8] &= ~0x40; //1 If the wanted effect is really setting the whole register to ~0x40 vs. all ones and the other bits are not affected independently, that should be reformulated just for clarity: > + state->tx_tuna[8] = ~0x40; //1 > + state->tx_tuna[8] = ~0x00; // 0 (note where the blanks are...) Olaf