This is a re-submission of previous patch series with the same subject but different number of patches. Hence v1. Driver ks7010 is currently using the WEXT interface, hopefully soon it will be converted to use CFG80211. This series is an attempt to clean up the host interface code in preparation for the conversion. Patch set is refactoring only, no changes to the program logic. Could patch 07 please be reviewed with some care, it touches code that uses pointers and memory allocation in a complex (to me) manner. Code is untested, builds on x86_64 and PowerPC. Changes since previous submission - remove file renames (patch 18 and patch 19) - remove spurious refactoring that had slipped into patch 'staging: ks7010: add enum sleep_mode_type' Tobin C. Harding (16): staging: ks7010: remove unnecessary address check staging: ks7010: remove unused local variable eap_key staging: ks7010: move skb null check near allocation staging: ks7010: remove magic numbers staging: ks7010: remove duplicate code staging: ks7010: clean memory allocation staging: ks7010: add hostif_generic_request() staging: ks7010: abstract connection status staging: ks7010: add enum sleep_mode_type staging: ks7010: fix checkpatch LINE_SPACING staging: ks7010: make abbreviation mgmt uniform staging: ks7010: remove cast from netdev_priv() staging: ks7010: continue from loop on unmatched mac staging: ks7010: clean up macro ps_confirm_wait_inc staging: ks7010: add enum multicast_filter_type staging: ks7010: fix enumeration tags drivers/staging/ks7010/eap_packet.h | 2 + drivers/staging/ks7010/ks7010_sdio.c | 6 +- drivers/staging/ks7010/ks_hostif.c | 360 ++++++++++++++--------------------- drivers/staging/ks7010/ks_hostif.h | 43 +++-- drivers/staging/ks7010/ks_wlan.h | 4 +- drivers/staging/ks7010/ks_wlan_net.c | 255 +++++++++++-------------- 6 files changed, 285 insertions(+), 385 deletions(-) -- 2.7.4 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel