Driver uses preprocessor directives to define multicast filter constants. These can be defined using an enumeration type. Doing so adds to the readability and gives the assists the compiler. Add enumeration type multicast_filter_type to replace preprocessor defined constants. Signed-off-by: Tobin C. Harding <me@xxxxxxxx> --- drivers/staging/ks7010/ks_hostif.h | 9 +++++---- 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/drivers/staging/ks7010/ks_hostif.h b/drivers/staging/ks7010/ks_hostif.h index 384d876..e679765 100644 --- a/drivers/staging/ks7010/ks_hostif.h +++ b/drivers/staging/ks7010/ks_hostif.h @@ -624,10 +624,11 @@ enum { SHORT_PREAMBLE }; -/* multicast filter */ -#define MCAST_FILTER_MCAST 0 -#define MCAST_FILTER_MCASTALL 1 -#define MCAST_FILTER_PROMISC 2 +enum multicast_filter_type { + MCAST_FILTER_MCAST, + MCAST_FILTER_MCASTALL, + MCAST_FILTER_PROMISC, +}; #define NIC_MAX_MCAST_LIST 32 -- 2.7.4 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel