Memory allocation code contains unneeded debug statements, failed kmalloc() calls typically do not require a debug message. Introduction of a local 'size' variable allows kmalloc() call to be marginally cleaner, still uses magic numbers but these require a more substantial fix. Moving the magic numbers onto a single line opens the way for further refactoring. Clean memory allocation code, remove debug statements. Signed-off-by: Tobin C. Harding <me@xxxxxxxx> --- drivers/staging/ks7010/ks_hostif.c | 7 ++----- 1 file changed, 2 insertions(+), 5 deletions(-) diff --git a/drivers/staging/ks7010/ks_hostif.c b/drivers/staging/ks7010/ks_hostif.c index d5ec487..2fefb92 100644 --- a/drivers/staging/ks7010/ks_hostif.c +++ b/drivers/staging/ks7010/ks_hostif.c @@ -1135,12 +1135,9 @@ int hostif_data_request(struct ks_wlan_private *priv, struct sk_buff *skb) netif_stop_queue(priv->net_dev); } - DPRINTK(4, "skb_buff length=%d\n", skb_len); - pp = kmalloc(hif_align_size(sizeof(*pp) + 6 + skb_len + 8), - KS_WLAN_MEM_FLAG); - + size = sizeof(*pp) + 6 + skb_len + 8; + pp = kmalloc(hif_align_size(size), KS_WLAN_MEM_FLAG); if (!pp) { - DPRINTK(3, "allocate memory failed..\n"); ret = -ENOMEM; goto err_kfree_skb; } -- 2.7.4 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel