On Sat, Dec 03, 2016 at 10:56:54AM +0100, Fernando Apesteguia wrote: > On Sat, Dec 03, 2016 at 09:51:13AM +0100, Greg KH wrote: > > On Fri, Dec 02, 2016 at 08:13:49PM +0100, Fernando Apesteguia wrote: > > > For the first lines of the patch, I opted to create a small function > > > instead of breaking the the line in a weird way. > > > > > > The other changes are simple ones. > > > > > > Signed-off-by: Fernando Apesteguia <fernando.apesteguia@xxxxxxxxx> > > > --- > > > drivers/staging/dgnc/dgnc_tty.c | 42 +++++++++++++++++++++++++---------------- > > > 1 file changed, 26 insertions(+), 16 deletions(-) > > > > > > diff --git a/drivers/staging/dgnc/dgnc_tty.c b/drivers/staging/dgnc/dgnc_tty.c > > > index af4bc86..835d448 100644 > > > --- a/drivers/staging/dgnc/dgnc_tty.c > > > +++ b/drivers/staging/dgnc/dgnc_tty.c > > > @@ -102,6 +102,7 @@ static int dgnc_tty_write(struct tty_struct *tty, const unsigned char *buf, > > > static void dgnc_tty_set_termios(struct tty_struct *tty, > > > struct ktermios *old_termios); > > > static void dgnc_tty_send_xchar(struct tty_struct *tty, char ch); > > > +static void dgnc_keep_line_low(struct channel_t *ch, const unsigned char line); > > > > > > static const struct tty_operations dgnc_tty_ops = { > > > .open = dgnc_tty_open, > > > @@ -786,6 +787,12 @@ void dgnc_check_queue_flow_control(struct channel_t *ch) > > > } > > > } > > > > > > +static void dgnc_keep_line_low(struct channel_t *ch, const unsigned char line) > > > +{ > > > + ch->ch_mostat &= ~(line); > > > + ch->ch_bd->bd_ops->assert_modem_signals(ch); > > > +} > > > > Your name here is odd, it is named because of what it does to the coding > > style, not to the logic of what is happening in the function itself, > > making it very confusing. > > It was a bad choice indeed :) but I didn't mean anything about the coding > style but about what the fuction does. It was meant to be read as: > "keep_signal_low" since the function puts (RTS/DTR) UART "line" to low. > > Would "keep_signal_low" be clear and representative of what the function does? It's not "keep", it is "change", right? I don't remember the context now, sorry, you could be correct... greg k-h _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel