Re: [PATCH v2 2/2] staging: slicoss: remove UPDATE_STATS_GB macro and inline code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Nov 24, 2016 at 8:41 PM, Markus Böhme <markus.boehme@xxxxxxxxxxx> wrote:
> On 11/24/2016 08:21 PM, Sergio Paracuellos wrote:
>> This patch removes UPDATE_STATS_GB macro in slic.h header file
>> and just inline code. This improve readability.
>>
>> Signed-off-by: Sergio Paracuellos <sergio.paracuellos@xxxxxxxxx>
>> ---
>>  drivers/staging/slicoss/slic.h    |  5 ----
>>  drivers/staging/slicoss/slicoss.c | 52 +++++++++++++++++++--------------------
>>  2 files changed, 25 insertions(+), 32 deletions(-)
>>
>> diff --git a/drivers/staging/slicoss/slic.h b/drivers/staging/slicoss/slic.h
>> index 2c05868..2893bdf 100644
>> --- a/drivers/staging/slicoss/slic.h
>> +++ b/drivers/staging/slicoss/slic.h
>> @@ -548,11 +548,6 @@ static inline void slic_flush_write(struct adapter *adapter)
>>       ioread32(adapter->regs + SLIC_REG_HOSTID);
>>  }
>>
>> -#define UPDATE_STATS_GB(largestat, newstat, oldstat)                     \
>> -{                                                                        \
>> -     (largestat) += ((newstat) - (oldstat));                          \
>> -}
>> -
>>  #if BITS_PER_LONG == 64
>>  #define   SLIC_GET_ADDR_LOW(_addr)  (u32)((u64)(_addr) & \
>>       0x00000000FFFFFFFF)
>> diff --git a/drivers/staging/slicoss/slicoss.c b/drivers/staging/slicoss/slicoss.c
>> index b6ec0a1..ffc7c45 100644
>> --- a/drivers/staging/slicoss/slicoss.c
>> +++ b/drivers/staging/slicoss/slicoss.c
>> @@ -1014,45 +1014,43 @@ static void slic_upr_request_complete(struct adapter *adapter, u32 isr)
>>                       break;
>>               }
>>
>> -             UPDATE_STATS_GB(stst->tcp.xmit_tcp_segs, stats->xmit_tcp_segs,
>> -                             old->xmit_tcp_segs);
>> +             stst->tcp.xmit_tcp_segs =
>> +                     stats->xmit_tcp_segs - old->xmit_tcp_segs;
>
> Missed this the first time, but the difference should be added to the
> value in stst:
>
>                 stst->tcp.xmit_tcp_segs +=
>                         stats->xmit_tcp_segs - old->xmit_tcp_segs;
>
> The same applies to the changes below.

True. I have just sent v3 with these fixed.

Thanks for let me know.

Cheers,
    Sergio Paracuellos
_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel




[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux