Fix two net drivers that declared enum constants that conflict with enum constants in linux/leds.h Create function that encapsulates actions taken during the adjust phy link step of phy state changes. Add support for led triggers on phy link state changes by adding a config option. When set the config option will create a set of led triggers for each phy device. Users can use the led triggers to represent link state changes on the phy. v2: * New patch that creates phy_adjust_link function to encapsulate actions taken when adjusting phy link during phy state changes * led trigger speed strings changed to match existing phy speed strings * New function that maps speeds to led triggers * Replace magic constants with definitions when declaring trigger name buffer and number of triggers. Josh Cartwright (1): phy,leds: add support for led triggers on phy link state change Zach Brown (3): skge: Change LED_OFF to LED_REG_OFF in marvel skge driver to avoid conflicts with leds namespace staging: rtl8712: Change _LED_STATE enum in rtl871x driver to avoid conflicts with LED namespace phy: Encapsulate actions performed during link state changes into function phy_adjust_link drivers/net/ethernet/marvell/skge.c | 4 +- drivers/net/ethernet/marvell/skge.h | 2 +- drivers/net/phy/Kconfig | 13 +- drivers/net/phy/Makefile | 1 + drivers/net/phy/phy.c | 22 +- drivers/net/phy/phy_device.c | 4 + drivers/net/phy/phy_led_triggers.c | 121 +++++++++++ drivers/staging/rtl8712/rtl8712_led.c | 388 +++++++++++++++++----------------- include/linux/phy.h | 9 + include/linux/phy_led_triggers.h | 52 +++++ 10 files changed, 410 insertions(+), 206 deletions(-) create mode 100644 drivers/net/phy/phy_led_triggers.c create mode 100644 include/linux/phy_led_triggers.h -- 2.7.4 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel