On Tue, Aug 02, 2016 at 09:51:18AM -0300, Mauro Carvalho Chehab wrote: > Em Tue, 2 Aug 2016 20:01:34 +0800 Baole Ni <baolex.ni@xxxxxxxxx> escreveu: > > > I find that the developers often just specified the numeric value > > when calling a macro which is defined with a parameter for access permission. > > As we know, these numeric value for access permission have had the corresponding macro, > > and that using macro can improve the robustness and readability of the code, > > thus, I suggest replacing the numeric parameter with the macro. > > Gah! > > A patch series with 1285 patches with identical subject! > > Please don't ever do something like that. My inbox is not trash! > > Instead, please group the changes per subsystem, and use different > names for each patch. Makes easier for people to review. Hi Baole, It may also be worth waiting for the first group to be reviewed before sending the other groups, in case the review comments change what you send later. > > -module_param(sg_mode, bool, 0644); > > +module_param(sg_mode, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); There's an S_IRUGO macro which makes the above just 'S_IRUGO | S_IWUSR'. Regards, Steve _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel