>> @@ -323,14 +323,14 @@ static void tx_device_task(void *dev) >> { >> struct ks_wlan_private *priv = (struct ks_wlan_private *)dev; >> struct tx_device_buffer *sp; >> - int rc = 0; >> >> DPRINTK(4, "\n"); >> if (cnt_txqbody(priv) > 0 >> && atomic_read(&priv->psstatus.status) != PS_SNOOZE) { >> sp = &priv->tx_dev.tx_dev_buff[priv->tx_dev.qhead]; >> if (priv->dev_state >= DEVICE_STATE_BOOT) { >> - rc = write_to_device(priv, sp->sendp, sp->size); >> + int rc = write_to_device(priv, sp->sendp, sp->size); > > This does not look appealing to me, neither the declaration in the middle > of the function, nor the intiialization to the result of a complex > expression, nor the separation of the call and the error checking code by > a blank line. There is nothing wrong with having the rc variable be > declared at the the top of the function, in its normal place. * Do you occasionally care for a refactoring like "Reduce scope of variable"? http://refactoring.com/catalog/reduceScopeOfVariable.html * How do you think about to remove the extra assignment at the beginning of this function implementation? Regards, Markus _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel