Re: [PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM register macros

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 17/05/16 18:22, Hartley Sweeten wrote:
On Tuesday, May 17, 2016 2:53 AM, Ian Abbott wrote:
Rename the macros defining values for the Serial EEPROM Control Register
to avoid CamelCase.

Signed-off-by: Ian Abbott <abbotti@xxxxxxxxx>
---
  drivers/staging/comedi/drivers/daqboard2000.c | 26 +++++++++++++-------------
  1 file changed, 13 insertions(+), 13 deletions(-)

diff --git a/drivers/staging/comedi/drivers/daqboard2000.c b/drivers/staging/comedi/drivers/daqboard2000.c
index fde0924..b3b68e8 100644
--- a/drivers/staging/comedi/drivers/daqboard2000.c
+++ b/drivers/staging/comedi/drivers/daqboard2000.c
@@ -116,12 +116,12 @@
  #define DAQBOARD2000_SUBSYSTEM_IDS4	0x0004	/* Daqboard/2000 - 4 Dacs */

Ian,

This board uses a PLX-9080 chip for the PCI interface.

If would be better to include <plx9080.h> and use the register/bit defines
to remove the magic numbers.

I was planning to do that, but want to massage plx9080.h a bit first.


The only PLX register used is PLX_CONTROL_REG (0x6c).

  /* Initialization bits for the Serial EEPROM Control Register */
-#define DAQBOARD2000_SECRProgPinHi      0x8001767e
-#define DAQBOARD2000_SECRProgPinLo      0x8000767e
-#define DAQBOARD2000_SECRLocalBusHi     0xc000767e
-#define DAQBOARD2000_SECRLocalBusLo     0x8000767e
-#define DAQBOARD2000_SECRReloadHi       0xa000767e
-#define DAQBOARD2000_SECRReloadLo       0x8000767e
+#define DAQBOARD2000_SECR_PROG_PIN_HI	0x8001767e
+#define DAQBOARD2000_SECR_PROG_PIN_LO	0x8000767e
+#define DAQBOARD2000_SECR_LOCAL_BUS_HI	0xc000767e
+#define DAQBOARD2000_SECR_LOCAL_BUS_LO	0x8000767e
+#define DAQBOARD2000_SECR_RELOAD_HI	0xa000767e
+#define DAQBOARD2000_SECR_RELOAD_LO	0x8000767e

These "Initialization bits" are just various combinations of the
PLX_CONTROL_REG bit defines (CTL_*) to toggle the various
EEPROM bits.

Yes, it would be better to read the control register and only change the bits of interest.

I plan to do some more work on this driver. This series is mainly to get the checkpatch warnings (well, most of them) out of the way first.

--
-=( Ian Abbott @ MEV Ltd.    E-mail: <abbotti@xxxxxxxxx> )=-
-=(                          Web: http://www.mev.co.uk/  )=-
_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel



[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux