On Thu, Mar 17, 2016 at 4:40 PM, Joe Perches <joe@xxxxxxxxxxx> wrote: > On Thu, 2016-03-17 at 16:33 -0400, Rob Clark wrote: >> On Thu, Mar 17, 2016 at 4:22 PM, Joe Perches <joe@xxxxxxxxxxx> wrote: >> > On Thu, 2016-03-17 at 15:43 -0300, Gustavo Padovan wrote: >> > > 2016-03-17 Gustavo Padovan <gustavo.padovan@xxxxxxxxxxxxxxx>: >> > > > 2016-03-17 Joe Perches <joe@xxxxxxxxxxx>: >> > > > > On Thu, 2016-03-17 at 14:30 -0300, Gustavo Padovan wrote: >> > > > > > This function had copies in 3 different files. Unify them in >> > > > > > kernel.h. >> > > > > This is only used by gpu/drm. >> > > > > >> > > > > I think this is a poor name for a generic function >> > > > > that would be in kernel.h. >> > > > > >> > > > > Isn't there an include file in linux/drm that's >> > > > > appropriate for this. Maybe drmP.h >> > > > > >> > > > > Maybe prefix this function name with drm_ too. >> > > > No, the next patch adds a user to drivers/staging (which will be moved >> > > > to drivers/dma-buf) soon. Maybe move to a different header in >> > > > include/linux/? not sure which one. >> > > > >> > > > > >> > > > > >> > > > > Also, there's this that might conflict: >> > > > > >> > > > > arch/powerpc/kernel/signal_32.c:#define to_user_ptr(p) ptr_to_compat(p) >> > > > > arch/powerpc/kernel/signal_32.c:#define to_user_ptr(p) ((unsigned long)(p)) >> > > > Right, I'll figure out how to replace these two too. >> > > The powerpc to_user_ptr has a different meaning from the one I'm adding >> > > in this patch. I propose we just rename powerpc's to_user_ptr to >> > > __to_user_ptr and leave the rest as is. >> > I think that's not a good idea, and you should really check >> > this concept with the powerpc folk (added to to:s and cc:ed) >> > >> > If it were really added, then the function meaning is incorrect. >> > >> > This is taking a u64, casting that to (unsigned long/uint_ptr_t), >> > then converting that to a user pointer. >> > >> > Does that naming and use make sense on x86-32 or arm32? >> > >> fwiw Gustavo's version of to_user_ptr() is in use on arm32 and arm64.. >> Not entirely sure what doesn't make sense about it > > It's a name that seems like it should be a straightforward > cast of a kernel pointer to a __user pointer like: > > static inline void __user *to_user_ptr(void *p) > { > return (void __user *)p; > } ahh, ok. I guess I was used to using it in the context of ioctl structs.. in that context u64 -> (void __user *) made more sense. Maybe uapi_to_ptr()? (ok, not super-creative.. maybe someone has a better idea) BR, -R > As a static function in a single file, it's not > great, but OK, fine, it's static. > > As a global function in kernel.h, it's misleading. > > _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel