[PATCH] staging: unisys: visornic: Made comments look nicer

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Made comments not break coding style guidlines and easier to read.

Signed-off-by: Gavin O'Leary <gavinoleary3@xxxxxxxxx>
---
 drivers/staging/unisys/visornic/visornic_main.c | 29 +++++++++++++++----------
 1 file changed, 17 insertions(+), 12 deletions(-)

diff --git a/drivers/staging/unisys/visornic/visornic_main.c b/drivers/staging/unisys/visornic/visornic_main.c
index 0519470..50ad44e 100644
--- a/drivers/staging/unisys/visornic/visornic_main.c
+++ b/drivers/staging/unisys/visornic/visornic_main.c
@@ -1215,11 +1215,13 @@ visornic_rx(struct uiscmdrsp *cmdrsp)
 					"repost_return failed");
 			return rx_count;
 		}
-		/* length rcvd is greater than firstfrag in this skb rcv buf  */
-		skb->tail += RCVPOST_BUF_SIZE;	/* amount in skb->data */
-		skb->data_len = skb->len - RCVPOST_BUF_SIZE;	/* amount that
-								   will be in
-								   frag_list */
+		/* length rcvd is greater than firstfrag in this skb rcv buf*/
+
+		/*amount in skb->data */
+		skb->tail += RCVPOST_BUF_SIZE;
+
+		/* amount that will be in frag_list */
+		skb->data_len = skb->len - RCVPOST_BUF_SIZE;
 	} else {
 		/* data fits in this skb - no chaining - do
 		 * PRECAUTIONARY check
@@ -1313,14 +1315,18 @@ visornic_rx(struct uiscmdrsp *cmdrsp)
 						break;
 					}
 				}
+
+				/* accept packet, dest matches a multicast
+				 * address
+				 */
 				if (found_mc)
-					break;	/* accept packet, dest
-						   matches a multicast
-						   address */
+					break;
 			}
+
+		/* accept packet, dest matches a multicast address */
 		} else if (skb->pkt_type == PACKET_HOST) {
-			break;	/* accept packet, h_dest must match vnic
-				   mac address */
+			break;
+
 		} else if (skb->pkt_type == PACKET_OTHERHOST) {
 			/* something is not right */
 			dev_err(&devdata->netdev->dev,
@@ -1618,8 +1624,7 @@ service_resp_queue(struct uiscmdrsp *cmdrsp, struct visornic_devdata *devdata,
 	unsigned long flags;
 	struct net_device *netdev;
 
-	/* TODO: CLIENT ACQUIRE -- Don't really need this at the
-	 * moment */
+	/* TODO: CLIENT ACQUIRE -- Don't really need this at the moment */
 	for (;;) {
 		if (!visorchannel_signalremove(devdata->dev->visorchannel,
 					       IOCHAN_FROM_IOPART,
-- 
1.9.1

_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel



[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux