On Mon, Jan 18, 2016 at 01:42:35PM +0000, Gujulan Elango, Hari Prasath (H.) wrote: > From: Hari Prasath Gujulan Elango <hgujulan@xxxxxxxxxxx> > > This patch move's a macro defined in the middle of a structure > definition to make it more readable. > > Signed-off-by: Hari Prasath Gujulan Elango <hgujulan@xxxxxxxxxxx> > --- > drivers/staging/wilc1000/wilc_sdio.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/staging/wilc1000/wilc_sdio.c b/drivers/staging/wilc1000/wilc_sdio.c > index e961b50..875ea68 100644 > --- a/drivers/staging/wilc1000/wilc_sdio.c > +++ b/drivers/staging/wilc1000/wilc_sdio.c > @@ -29,12 +29,12 @@ static const struct sdio_device_id wilc_sdio_ids[] = { > }; > > #define WILC_SDIO_BLOCK_SIZE 512 > +#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */ > > typedef struct { > bool irq_gpio; > u32 block_size; > int nint; > -#define MAX_NUN_INT_THRPT_ENH2 (5) /* Max num interrupts allowed in registers 0xf7, 0xf8 */ No, this is a very common way to show that this define is for this field in the structure, please don't change that. sorry, greg k-h _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel