[PATCH 00/18] staging: sm750fb: change some register fields defines

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

This is the first set of patches that aim to replace custom defines for
register fields. The ultimate goal is to have MSB:LSB notation for register
fields and FIELD_* macros removed. 

Mike Rapoport (18):
  staging: sm750fb: hw_sm750(le)_deWait: rename dwVal to val
  staging: sm750fb: use BIT macro for DE_STATE1 single-bit field
  staging: sm750fb: use BIT macro for DE_STATE2 single-bit fields
  staging: sm750fb: remove unused DE_STATE2_DE_RESERVED
  staging: sm750fb: use BIT macro for SYSTEM_CTRL single-bit fields
  staging: sm750fb: change definition of SYSTEM_CTRL multi-bit fields
  staging: sm750fb: ddk750_initHw: rename ulReg to reg
  staging: sm750fb: use BIT macro for MISC_CTRL single-bit fields
  staging: sm750fb: ddk750_sii164: fix defines for i2c{Read,Write}reg
  staging: sm750fb: use BIT macro for GPIO_MUX single-bit fields
  staging: sm750fb: change definition of MISC_CTRL multi-bit fields
  staging: sm750fb: use BIT macro for CURRENT_GATE single-bit fields
  staging: sm750fb: set{Memory,Master}Clock: rename ulReg to reg
  staging: sm750fb: change definition of CURRENT_GATE multi-bit fields
  staging: sm750fb: use BIT macro for MODE0_GATE single-bit fields
  staging: sm750fb: change definition of MODE0_GATE multi-bit fields
  staging: sm750fb: use BIT macro for POWER_MODE_CTRL single-bit fields
  staging: sm750fb: change definition of POWER_MODE_CTRL multi-bit field

 drivers/staging/sm750fb/ddk750_chip.c    |  83 +++--
 drivers/staging/sm750fb/ddk750_display.c |  24 +-
 drivers/staging/sm750fb/ddk750_hwi2c.c   |   7 +-
 drivers/staging/sm750fb/ddk750_power.c   |  43 ++-
 drivers/staging/sm750fb/ddk750_power.h   |  11 +-
 drivers/staging/sm750fb/ddk750_reg.h     | 503 ++++++++++---------------------
 drivers/staging/sm750fb/ddk750_sii164.c  |   4 +-
 drivers/staging/sm750fb/sm750_hw.c       |  57 ++--
 8 files changed, 256 insertions(+), 476 deletions(-)

-- 
1.9.1

_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel



[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux