On Sun, Sep 20, 2015 at 10:09:22AM +0200, Mateusz Kulikowski wrote: > Use naming schema found in other rtlwifi devices. > Rename rtl8192_init to _rtl92e_init. > > Signed-off-by: Mateusz Kulikowski <mateusz.kulikowski@xxxxxxxxx> > --- > drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c > index 52e1e27..63bb467 100644 > --- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c > +++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c > @@ -1063,7 +1063,7 @@ static short rtl8192_get_channel_map(struct net_device *dev) > return 0; > } > > -static short rtl8192_init(struct net_device *dev) > +static short _rtl92e_init(struct net_device *dev) _ as a prefix for a function name? That's horrid, and is not something we want to do in the kernel. Ick, that's what the drivers/net/wireless/rtlwifi/ drivers do. Hm, are you really thinking you can clean this driver up enough to merge it into that portion of the kernel? I think the naming of the functions is the least of the problems / worries here, why did you choose this task to do first? thanks, greg k-h _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel