> -----Original Message----- > From: jakeo@xxxxxxxxxxxxx [mailto:jakeo@xxxxxxxxxxxxx] > Sent: Thursday, September 10, 2015 5:01 PM > To: gregkh@xxxxxxxxxxxxxxxxxxx; KY Srinivasan <kys@xxxxxxxxxxxxx>; linux- > kernel@xxxxxxxxxxxxxxx; devel@xxxxxxxxxxxxxxxxxxxxxx; olaf@xxxxxxxxx; > apw@xxxxxxxxxxxxx; vkuznets@xxxxxxxxxx; linux-pci@xxxxxxxxxxxxxxx; > bhelgaas@xxxxxxxxxx; tglx@xxxxxxxxxxxxx > Cc: Jake Oshins <jakeo@xxxxxxxxxxxxx> > Subject: [PATCH v2 06/12] drivers:hv: Export do_hypercall() > > From: Jake Oshins <jakeo@xxxxxxxxxxxxx> > > This patch exposes the function that hv_vmbus.ko uses to make hypercalls. > This > is necessary for retargeting an interrupt when it is given a new affinity. > > Signed-off-by: Jake Oshins <jakeo@xxxxxxxxxxxxx> > --- > drivers/hv/hv.c | 3 ++- > include/linux/hyperv.h | 1 + > 2 files changed, 3 insertions(+), 1 deletion(-) > > diff --git a/drivers/hv/hv.c b/drivers/hv/hv.c > index 6341be8..6d01649 100644 > --- a/drivers/hv/hv.c > +++ b/drivers/hv/hv.c > @@ -91,7 +91,7 @@ static int query_hypervisor_info(void) > /* > * do_hypercall- Invoke the specified hypercall > */ > -static u64 do_hypercall(u64 control, void *input, void *output) > +u64 do_hypercall(u64 control, void *input, void *output) do_hypercall() is not an appropriate name for a function to be exported. I plan to take the base vmbus patches through Greg's tree and if it is ok with you, I will change the name of this function. Regards, K. Y _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel