On Sat, Aug 08, 2015 at 02:31:40PM -0700, Greg KH wrote: > > int libcfs_register_ioctl(struct libcfs_ioctl_handler *hand); > > int libcfs_deregister_ioctl(struct libcfs_ioctl_handler *hand); > > -int libcfs_ioctl_getdata(char *buf, char *end, void *arg); > > -int libcfs_ioctl_popdata(void *arg, void *buf, int size); > > +int libcfs_ioctl_getdata(char *buf, char *end, void __user *arg); > > +int libcfs_ioctl_popdata(void __user *arg, void *buf, int size); > > This isn't going to work well at all, please see the mailing list > archives for why. > This one moves the warnings around, yes, but it moves them closer to where the warnings belong. I look at it like an improvement. That said, I think we should just get rid of these functions and call copy_from/to_user() directly. Abstracting it out just makes the code harder to read. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel