Write a better subject line. On Thu, Jul 23, 2015 at 09:53:18PM -0700, Joshua Clayton wrote: > change instances SupportedRates to compliant and sane "rates" > This change in no way harms readability, and brings several lines > under the 80 character limit. > Yeah, but it does a some other stuff as well like removing casts. > - while ((pcur_bss->SupportedRates[i] != 0) && > - (pcur_bss->SupportedRates[i] != 0xFF)) { > - rate = pcur_bss->SupportedRates[i] & 0x7F; > + while (pcur_bss->rates[i] && (pcur_bss->rates[i] != 0xFF)) { > + rate = pcur_bss->rates[i] & 0x7F; > if (rate > max_rate) > max_rate = rate; > wrqu->bitrate.fixed = 0; /* no auto select */ I actually like the != 0 here because we're talking about the number zero. It should look like this: while (pcur_bss->rates[i] != 0 && pcur_bss->rates[i] != 0xFF) { But removing the parens is something for a different patch. I use a script to help review these so when you mix different changes together it means there is more manual review work for me. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel