On Fri, 2015-07-03 at 12:58 +0200, Krzysztof Hałasa wrote: > Joe Perches <joe@xxxxxxxxxxx> writes: > > > -#define LCONSOLE(mask, format, ...) CDEBUG(D_CONSOLE | (mask), format, ## __VA_ARGS__) > > -#define LCONSOLE_INFO(format, ...) CDEBUG_LIMIT(D_CONSOLE, format, ## __VA_ARGS__) > > -#define LCONSOLE_WARN(format, ...) CDEBUG_LIMIT(D_CONSOLE | D_WARNING, format, ## __VA_ARGS__) > > -#define LCONSOLE_ERROR_MSG(errnum, format, ...) CDEBUG_LIMIT(D_CONSOLE | D_ERROR, \ > > - "%x-%x: " format, errnum, LERRCHKSUM(errnum), ## __VA_ARGS__) > > -#define LCONSOLE_ERROR(format, ...) LCONSOLE_ERROR_MSG(0x00, format, ## __VA_ARGS__) > > +#define LCONSOLE(mask, fmt, ...) \ > > + CDEBUG(D_CONSOLE | (mask), fmt, ##__VA_ARGS__) > > +#define LCONSOLE_INFO(fmt, ...) \ > > + CDEBUG_LIMIT(D_CONSOLE, fmt, ##__VA_ARGS__) > > +#define LCONSOLE_WARN(fmt, ...) \ > > + CDEBUG_LIMIT(D_CONSOLE | D_WARNING, fmt, ##__VA_ARGS__) > > +#define LCONSOLE_ERROR_MSG(errnum, fmt, ...) \ > > + CDEBUG_LIMIT(D_CONSOLE | D_ERROR, "%x-%x: " fmt, \ > > + errnum, LERRCHKSUM(errnum), ##__VA_ARGS__) > > I don't find it better, actually I think it's much harder to read. > > Maybe that's just me. > > Call me extremist, but I think I could even like the following :-) > > #define CWARN(format, ...) CDEBUG_LIMIT(D_WARNING, format, ## __VA_ARGS__) > #define CERROR(format, ...) CDEBUG_LIMIT(D_ERROR, format, ## __VA_ARGS__) > #define CNETERR(format, ...) CDEBUG_LIMIT(D_NETERROR, format, ## __VA_ARGS__) > #define CEMERG(format, ...) CDEBUG_LIMIT(D_EMERG, format, ## __VA_ARGS__) Nah, you're not an extremist, you're just preferring narrowly localized readability over global consistency. That's fine and all, until you come up to LCONSOLE_ERROR_MSG type use which blows the nice old formatting up. So what I suggested is just a simple consistency thing. _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel