On Fri, May 15, 2015 at 12:51:29AM +0200, Luca Ceresoli wrote: > >>@@ -1003,7 +1003,7 @@ static int _netdev_open(struct net_device *pnetdev) > >> pr_info("MAC Address = %pM\n", pnetdev->dev_addr); > >> > >> status = rtw_start_drv_threads(padapter); > >>- if (status == _FAIL) { > >>+ if (status != 0) { > > > >This patch is fine as-is but actually, status is an unsigned int and > >we're storing negatives and error codes so that's a bit unfortunate. > > You're right. The "status" variable should become an int, and perhaps be > renamed to err. Yeah, err is better. But I would leave "status" for the untransitioned returns because they mean different things. At the end you can grep for "status" to see if there is anything left to transition. > > Thanks for pointing out. > > Overall I understand you agree on the principle, correct? Yeah. We need to move to normal return codes. Change the static functions first probably because those are easiest to review. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel