On Sun, Apr 19, 2015 at 05:43:51PM -0300, Gaston Gonzalez wrote: > Silence the following sparse warning: > > drivers/staging/rtl8192u/ieee80211/ieee80211_crypt_tkip.c:184:16: warning: cast to restricted __le16 > We have a tkip_mixing_phase2() function in net/mac80211/tkip.c. That's probably the better thing. > Signed-off-by: Gaston Gonzalez <gascoar@xxxxxxxxx> > --- > .../rtl8192u/ieee80211/ieee80211_crypt_tkip.c | 22 +++++++++++----------- > 1 file changed, 11 insertions(+), 11 deletions(-) > > diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_crypt_tkip.c b/drivers/staging/rtl8192u/ieee80211/ieee80211_crypt_tkip.c > index e815c81..efa6983 100644 > --- a/drivers/staging/rtl8192u/ieee80211/ieee80211_crypt_tkip.c > +++ b/drivers/staging/rtl8192u/ieee80211/ieee80211_crypt_tkip.c > @@ -179,1 +179,1 @@ static inline u16 Mk16(u8 hi, u8 lo) > } > > > -static inline u16 Mk16_le(u16 *v) > +static inline u16 Mk16_le(__le16 *v) > { > return le16_to_cpu(*v); > } Mk16_le() is a bad function name and as we can see from tkip.c it just duplicates get_unaligned_le16(). Better to make TK void pointer instead of a u8 pointer (because it doesn't point to u8s so we have to cast it every time we use it). This is another trick I learned from tkip.c. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel