This patch series is a renamed successor of "[PATCH] Drivers: hv: vmbus: serialize Offer and Rescind offer processing". Changes from v2: - Rename labels in vmbus_process_offer() ("out" -> "done_init_rescind" in PATCH 3/3, "error" -> "err_free_chan" in PATCH 1/3) [Dan Carpenter] - Invert condition, update comment, and remove "out" label in vmbus_onoffer_rescind() Changes from v1: - Separate vmbus_device_create() return value check [K. Y. Srinivasan] - Do not lose a rescind offer received during offer processing. Use renamed (in [PATCH v2 2/3]) spinlock to protect simulteneous test-and-set workflow for rescind and work fields. [K. Y. Srinivasan] Vitaly Kuznetsov (3): Drivers: hv: check vmbus_device_create() return value in vmbus_process_offer() Drivers: hv: rename sc_lock to the more generic lock Drivers: hv: vmbus: serialize Offer and Rescind offer drivers/hv/channel.c | 6 +++--- drivers/hv/channel_mgmt.c | 50 ++++++++++++++++++++++++++++++++--------------- include/linux/hyperv.h | 7 ++++++- 3 files changed, 43 insertions(+), 20 deletions(-) -- 1.9.3 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel