On Mon, Jan 19, 2015 at 05:56:11PM +0100, Vitaly Kuznetsov wrote: > vmbus_device_create() result is not being checked in vmbus_process_offer() and > it can fail if kzalloc() fails. Add the check and do minor cleanup to avoid > additional duplication of "free_channel(); return;" block. > > Reported-by: Jason Wang <jasowang@xxxxxxxxxx> > Signed-off-by: Vitaly Kuznetsov <vkuznets@xxxxxxxxxx> "out" is always a bad name for a label. It's too vague. It implies that the code uses "One Err" style error handling which is bug prone and I've ranted about that in the past so I won't here. This kind of coding is buggier than direct returns. But recently I've been looking at bugs where we return zero where the code should return a negative error code and, wow, do I hate "out" labels! if (function_whatever(xxx)) goto out; [ thousands of lines removed. ] out: return ret; Oh crap... Did the coder mean to return success or not??? If you use a direct return then the code looks like: if (function_whatever(xxx)) return 0; In that case, you can immediately see that the coder typed "0" deliberately. Direct returns are best. I guess that's not directly related to this code. But I didn't know that until I read to the bottom of the patch and I already had this rant prepared in my head ready to go... "error" is a crap label name because it doesn't tell you what the code does. A better name is "err_free_chan" or something which talks about freeing the channel. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel