Re: [PATCH] staging: rtl8723au: Fixed multiple space issues

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, 2014-12-27 at 03:42 -0500, Matthew Emerson wrote:
> Fixed multiple space issues found by checkpatch.pl in
> drivers/staging/rtl8723au/core/rtw_ap.c

Hello.

Please strive for more than simple robotic like
adherence to checkpatch messages.

A lot of the time, there is a better way.

> diff --git a/drivers/staging/rtl8723au/core/rtw_ap.c b/drivers/staging/rtl8723au/core/rtw_ap.c
[]
> @@ -897,7 +897,7 @@ int rtw_check_beacon_data23a(struct rtw_adapter *padapter,
>  	pairwise_cipher = 0;
>  	psecuritypriv->wpa_group_cipher = 0;
>  	psecuritypriv->wpa_pairwise_cipher = 0;
> -	for (p = ie; ;p += (ie_len + 2)) {
> +	for (p = ie; ; p += (ie_len + 2)) {

While it's arguably true that the ; is misplaced,
the loop control logic is probably better rewritten
for clarity here instead.

[]

> @@ -1871,7 +1871,7 @@ void stop_ap_mode23a(struct rtw_adapter *padapter)
>  	pmlmeext->bstart_bss = false;
>  
>  	/* reset and init security priv , this can refine with rtw_reset_securitypriv23a */
> -	memset((unsigned char *)&padapter->securitypriv, 0, sizeof (struct security_priv));
> +	memset((unsigned char *)&padapter->securitypriv, 0, sizeof(struct security_priv));

unnecessary cast too.

More likely this style would be nicer:

	memset(&adapter->securitypriv, 0, sizeof(adapter->securitypriv));

You could also use a compound literal.


_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel



[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux